Уведомления на почту о подключении к Wi-Fi
Поиск
  • SUPPORT 72

Уведомления на почту о подключении к Wi-Fi

Встала задача получать уведомления на почту о подключении к Wi-Fi микротика.

Это может помочь для статистики, контроля или просто как информативный сервис. К примеру, клиент оказался в зоне действия Вашей сети, подключился и вы получили е-мейл.


Итак, прежде всего необходимо настроить сам е-мейл в разделе Tools - E-mail, в нашем случае почтовым сервером будет Яндекс











Как только убедились, что тестовое письмо уходит, идем в раздел

IP - DHCP. На вкладке DHCP выбираем сервер раздачи адресов, который будет отслеживать подключения, и внутри него выбираем вкладку Script, в поле Lease Script вводим вот такой код:


Сам код:


  1. :if ($leaseBound = 1) do={

  2. /ip dhcp-server lease;

  3. :foreach i in=[find dynamic=yes] do={

  4. :local dhcpip

  5. :set dhcpip [ get $i address ];

  6. :local clientid

  7. :set clientid [get $i host-name];

  8. :if ($leaseActIP = $dhcpip) do={

  9. :local comment "New IP"

  10. :set comment ( $comment . ": " . $dhcpip . ": " . $clientid);

  11. /log error $comment;

  12. / tool e-mail send from="имя@yandex.ru" server=87.250.250.38 to= "имя@yandex.ru" body="IP: $leaseActIP;

  13. Host: $clientid;

  14. Mac: $leaseActMAC;

  15. SRV: $leaseServerName;" subject="Free Wi-Fi Connection"

  16. }

  17. }

  18. }


Теперь подключаемся вашим майфуном в эту сеть, проверяем почту и улыбаемся!)



Просмотров: 0